#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "C*(at){2,}"
Local $sString = "Now we are looking for the pattern of zero or more capital "C"s followed by the letters "at" repeated two or more times. This means that we'll always match the pattern "atat", but if there is also one or more capital "C"s in front of the "atat", then we'll match it to." & @CRLF & _
"This pattern will not match "Cat" since the "at" is not repeated." & @CRLF & _
"It will match the first five letters of "Catatonic" since that fits our pattern." & @CRLF & _
"It will the match the four letters after the "c" in "catatonic"." & @CRLF & _
"It will match all of the following: "CCCCCCCCCCCCCCCCCCCatat""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")