const regex = /C*(at){2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('C*(at){2,}', 'g')
const str = `Now we are looking for the pattern of zero or more capital "C"s followed by the letters "at" repeated two or more times. This means that we'll always match the pattern "atat", but if there is also one or more capital "C"s in front of the "atat", then we'll match it to.
This pattern will not match "Cat" since the "at" is not repeated.
It will match the first five letters of "Catatonic" since that fits our pattern.
It will the match the four letters after the "c" in "catatonic".
It will match all of the following: "CCCCCCCCCCCCCCCCCCCatat"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}