// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"C*(at){2,}").unwrap();
let string = "Now we are looking for the pattern of zero or more capital \"C\"s followed by the letters \"at\" repeated two or more times. This means that we'll always match the pattern \"atat\", but if there is also one or more capital \"C\"s in front of the \"atat\", then we'll match it to.
This pattern will not match \"Cat\" since the \"at\" is not repeated.
It will match the first five letters of \"Catatonic\" since that fits our pattern.
It will the match the four letters after the \"c\" in \"catatonic\".
It will match all of the following: \"CCCCCCCCCCCCCCCCCCCatat\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}