import Foundation
let pattern = #"C*(at){2,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Now we are looking for the pattern of zero or more capital "C"s followed by the letters "at" repeated two or more times. This means that we'll always match the pattern "atat", but if there is also one or more capital "C"s in front of the "atat", then we'll match it to.
This pattern will not match "Cat" since the "at" is not repeated.
It will match the first five letters of "Catatonic" since that fits our pattern.
It will the match the four letters after the "c" in "catatonic".
It will match all of the following: "CCCCCCCCCCCCCCCCCCCatat"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)