import re
regex = re.compile(r"C*(at){2,}")
test_str = ("Now we are looking for the pattern of zero or more capital \"C\"s followed by the letters \"at\" repeated two or more times. This means that we'll always match the pattern \"atat\", but if there is also one or more capital \"C\"s in front of the \"atat\", then we'll match it to.\n"
"This pattern will not match \"Cat\" since the \"at\" is not repeated.\n"
"It will match the first five letters of \"Catatonic\" since that fits our pattern.\n"
"It will the match the four letters after the \"c\" in \"catatonic\".\n"
"It will match all of the following: \"CCCCCCCCCCCCCCCCCCCatat\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")