use strict;
my $str = 'Now we are looking for the pattern of zero or more capital "C"s followed by the letters "at" repeated two or more times. This means that we\'ll always match the pattern "atat", but if there is also one or more capital "C"s in front of the "atat", then we\'ll match it to.
This pattern will not match "Cat" since the "at" is not repeated.
It will match the first five letters of "Catatonic" since that fits our pattern.
It will the match the four letters after the "c" in "catatonic".
It will match all of the following: "CCCCCCCCCCCCCCCCCCCatat"';
my $regex = qr/C*(at){2,}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}