using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"C*(at){2,}";
string input = @"Now we are looking for the pattern of zero or more capital ""C""s followed by the letters ""at"" repeated two or more times. This means that we'll always match the pattern ""atat"", but if there is also one or more capital ""C""s in front of the ""atat"", then we'll match it to.
This pattern will not match ""Cat"" since the ""at"" is not repeated.
It will match the first five letters of ""Catatonic"" since that fits our pattern.
It will the match the four letters after the ""c"" in ""catatonic"".
It will match all of the following: ""CCCCCCCCCCCCCCCCCCCatat""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}