using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{8}";
string substitution = @"^\d{15}[0-9]";
string input = @"07016";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}