use strict;
my $str = '07016';
my $regex = qr/^\d{8}/p;
my $subst = '^\\d{15}[0-9]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";