const regex = /^\d{8}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{8}', 'g')
const str = `07016`;
const subst = `^\d{15}[0-9]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);