// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\d{8}").unwrap();
let string = "07016";
let substitution = "^\\d{15}[0-9]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}