# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\w+_([a-zA-Z]+)_\d+/$1/gm;t' <<< "MyFile_TEST_INDIA_20160728
MyFile_TEST_AMERICA_20160728
MyFile_TEST_GERMANY_20160728"