re = /^\w+_([a-zA-Z]+)_\d+/m
str = 'MyFile_TEST_INDIA_20160728
MyFile_TEST_AMERICA_20160728
MyFile_TEST_GERMANY_20160728'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result