import re
regex = re.compile(r"^\w+_([a-zA-Z]+)_\d+", flags=re.MULTILINE)
test_str = ("MyFile_TEST_INDIA_20160728\n"
"MyFile_TEST_AMERICA_20160728 \n"
"MyFile_TEST_GERMANY_20160728")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)