const regex = /^\w+_([a-zA-Z]+)_\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+_([a-zA-Z]+)_\\d+', 'gm')
const str = `MyFile_TEST_INDIA_20160728
MyFile_TEST_AMERICA_20160728
MyFile_TEST_GERMANY_20160728`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);