package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+_([a-zA-Z]+)_\d+`)
var str = `MyFile_TEST_INDIA_20160728
MyFile_TEST_AMERICA_20160728
MyFile_TEST_GERMANY_20160728`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}