import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+_([a-zA-Z]+)_\\d+";
final String string = "MyFile_TEST_INDIA_20160728\n"
+ "MyFile_TEST_AMERICA_20160728 \n"
+ "MyFile_TEST_GERMANY_20160728";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}