#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9.!#$%&'*+/=?^_`{|}~-]+@[a-zA-Z0-9-]+(?:\.[a-zA-Z0-9-]+)*$"
Local $sString = "mysite@ourearth.com" & @CRLF & _
"my.ownsite@ourearth.org" & @CRLF & _
"mysite@you.me.net" & @CRLF & _
"" & @CRLF & _
"mysite.ourearth.com" & @CRLF & _
"mysite@.com.my" & @CRLF & _
"@you.me.net" & @CRLF & _
"mysite123@gmail.b" & @CRLF & _
"mysite@.org.org" & @CRLF & _
".mysite@mysite.org" & @CRLF & _
"mysite()*@gmail.com" & @CRLF & _
"mysite..1234@yahoo.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")