use strict;
my $str = 'mysite@ourearth.com
my.ownsite@ourearth.org
mysite@you.me.net
mysite.ourearth.com
mysite@.com.my
@you.me.net
mysite123@gmail.b
mysite@.org.org
.mysite@mysite.org
mysite()*@gmail.com
mysite..1234@yahoo.com
';
my $regex = qr/^[a-zA-Z0-9.!#$%&'*+/=?^_`{|}~-]+@[a-zA-Z0-9-]+(?:\.[a-zA-Z0-9-]+)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}