// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9.!#$%&'*+/=?^_`{|}~-]+@[a-zA-Z0-9-]+(?:\.[a-zA-Z0-9-]+)*$").unwrap();
let string = "mysite@ourearth.com
my.ownsite@ourearth.org
mysite@you.me.net
mysite.ourearth.com
mysite@.com.my
@you.me.net
mysite123@gmail.b
mysite@.org.org
.mysite@mysite.org
mysite()*@gmail.com
mysite..1234@yahoo.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}