using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9.!#$%&'*+/=?^_`{|}~-]+@[a-zA-Z0-9-]+(?:\.[a-zA-Z0-9-]+)*$";
string input = @"mysite@ourearth.com
my.ownsite@ourearth.org
mysite@you.me.net
mysite.ourearth.com
mysite@.com.my
@you.me.net
mysite123@gmail.b
mysite@.org.org
.mysite@mysite.org
mysite()*@gmail.com
mysite..1234@yahoo.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}