import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9.!#$%&'*+/=?^_`\\{|\\}~-]+@[a-zA-Z0-9-]+(?:\\.[a-zA-Z0-9-]+)*$";
final String string = "mysite@ourearth.com\n"
+ "my.ownsite@ourearth.org\n"
+ "mysite@you.me.net\n\n"
+ "mysite.ourearth.com\n"
+ "mysite@.com.my\n"
+ "@you.me.net\n"
+ "mysite123@gmail.b\n"
+ "mysite@.org.org\n"
+ ".mysite@mysite.org\n"
+ "mysite()*@gmail.com\n"
+ "mysite..1234@yahoo.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}