import re
regex = re.compile(r"^[a-zA-Z0-9.!#$%&'*+/=?^_`{|}~-]+@[a-zA-Z0-9-]+(?:\.[a-zA-Z0-9-]+)*$", flags=re.MULTILINE)
test_str = ("mysite@ourearth.com\n"
"my.ownsite@ourearth.org\n"
"mysite@you.me.net\n\n"
"mysite.ourearth.com\n"
"mysite@.com.my\n"
"@you.me.net\n"
"mysite123@gmail.b\n"
"mysite@.org.org\n"
".mysite@mysite.org\n"
"mysite()*@gmail.com\n"
"mysite..1234@yahoo.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")