package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9.!#$%&'*+/=?^_`{|}~-]+@[a-zA-Z0-9-]+(?:\.[a-zA-Z0-9-]+)*$`)
var str = `mysite@ourearth.com
my.ownsite@ourearth.org
mysite@you.me.net
mysite.ourearth.com
mysite@.com.my
@you.me.net
mysite123@gmail.b
mysite@.org.org
.mysite@mysite.org
mysite()*@gmail.com
mysite..1234@yahoo.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}