# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https{0,1}:\\/\\/.{1,}/$0/g;t' <<< "http://www.egghead.io
http://
https://www.egghead.io"