import Foundation
let pattern = #"https{0,1}:\/\/.{1,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://www.egghead.io
http://
https://www.egghead.io
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)