// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https{0,1}:\/\/.{1,}").unwrap();
let string = "http://www.egghead.io
http://
https://www.egghead.io";
let substitution = "$0";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}