const regex = /https{0,1}:\/\/.{1,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https{0,1}:\\\/\\\/.{1,}', 'g')
const str = `http://www.egghead.io
http://
https://www.egghead.io`;
const subst = `$0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);