#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "https{0,1}:\/\/.{1,}"
Local $sString = "http://www.egghead.io" & @CRLF & _
"http://" & @CRLF & _
"https://www.egghead.io"
Local $sSubst = "$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)