use strict;
my $str = 'http://www.egghead.io
http://
https://www.egghead.io';
my $regex = qr/https{0,1}:\/\/.{1,}/p;
my $subst = '$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";