using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https{0,1}:\/\/.{1,}";
string substitution = @"$0";
string input = @"http://www.egghead.io
http://
https://www.egghead.io";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}