#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "jest.mock\(\s*\"(?:\.\./){4}src/components/(?P<name>\S+)\",\s*\(\) => \"(?P=name)\"\s*\);"
Local $sString = "// BEEP BOOP! I am a generated file. Don't edit me manually." & @CRLF & _
"// @flow" & @CRLF & _
"" & @CRLF & _
"import initStoryshots from "@storybook/addon-storyshots";" & @CRLF & _
"jest.mock(" & @CRLF & _
" "../../../../src/components/BorderlessButton"," & @CRLF & _
" () => "BorderlessButton"" & @CRLF & _
");" & @CRLF & _
"jest.mock("../../../../src/components/BorderlessButton", () => "BorderlessButton");" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"initStoryshots({" & @CRLF & _
" storyKindRegex: /^IconButton$/" & @CRLF & _
"});" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")