re = /jest.mock\(\s*\"(?:\.\.\/){4}src\/components\/(?P<name>\S+)\",\s*\(\) => \"(?P=name)\"\s*\);/
str = '// BEEP BOOP! I am a generated file. Don\'t edit me manually.
// @flow
import initStoryshots from "@storybook/addon-storyshots";
jest.mock(
"../../../../src/components/BorderlessButton",
() => "BorderlessButton"
);
jest.mock("../../../../src/components/BorderlessButton", () => "BorderlessButton");
initStoryshots({
storyKindRegex: /^IconButton$/
});
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end