using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"jest.mock\(\s*\""(?:\.\./){4}src/components/(?P<name>\S+)\"",\s*\(\) => \""(?P=name)\""\s*\);";
string input = @"// BEEP BOOP! I am a generated file. Don't edit me manually.
// @flow
import initStoryshots from ""@storybook/addon-storyshots"";
jest.mock(
""../../../../src/components/BorderlessButton"",
() => ""BorderlessButton""
);
jest.mock(""../../../../src/components/BorderlessButton"", () => ""BorderlessButton"");
initStoryshots({
storyKindRegex: /^IconButton$/
});
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}