import re
regex = re.compile(r"jest.mock\(\s*\"(?:\.\./){4}src/components/(?P<name>\S+)\",\s*\(\) => \"(?P=name)\"\s*\);")
test_str = ("// BEEP BOOP! I am a generated file. Don't edit me manually.\n"
"// @flow\n\n"
"import initStoryshots from \"@storybook/addon-storyshots\";\n"
"jest.mock(\n"
" \"../../../../src/components/BorderlessButton\",\n"
" () => \"BorderlessButton\"\n"
");\n"
"jest.mock(\"../../../../src/components/BorderlessButton\", () => \"BorderlessButton\");\n\n\n"
"initStoryshots({\n"
" storyKindRegex: /^IconButton$/\n"
"});\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")