use strict;
my $str = '// BEEP BOOP! I am a generated file. Don\'t edit me manually.
// @flow
import initStoryshots from "@storybook/addon-storyshots";
jest.mock(
"../../../../src/components/BorderlessButton",
() => "BorderlessButton"
);
jest.mock("../../../../src/components/BorderlessButton", () => "BorderlessButton");
initStoryshots({
storyKindRegex: /^IconButton$/
});
';
my $regex = qr/jest.mock\(\s*\"(?:\.\./){4}src/components/(?P<name>\S+)\",\s*\(\) => \"(?P=name)\"\s*\);/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}