# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\(File Attachment:\s(.*)?\)[\r\n]?//gm;t' <<< "dsfasdljkfjalkf
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
dfsdfdsf
dsfdsfdsf
sdfdsfdsf
sdf"