const regex = /\(File Attachment:\s(.*)?\)[\r\n]?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(File Attachment:\\s(.*)?\\)[\\r\\n]?', 'gm')
const str = `dsfasdljkfjalkf
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
dfsdfdsf
dsfdsfdsf
sdfdsfdsf
sdf`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);