package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(File Attachment:\s(.*)?\)[\r\n]?`)
var str = `dsfasdljkfjalkf
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
dfsdfdsf
dsfdsfdsf
sdfdsfdsf
sdf`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}