import Foundation
let pattern = #"\(File Attachment:\s(.*)?\)[\r\n]?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
dsfasdljkfjalkf
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
dfsdfdsf
dsfdsfdsf
sdfdsfdsf
sdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)