$re = '/\(File Attachment:\s(.*)?\)[\r\n]?/m';
$str = 'dsfasdljkfjalkf
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
dfsdfdsf
dsfdsfdsf
sdfdsfdsf
sdf';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;