package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+\.)\s+([^\r\n]+)(?:[\r\n]*)`)
var str = `
This is a test of the agenda and objectives format
This shouldn’t get picked up
Dasdasdasd d asda sd : asd obe: sad neither shood this
Objective: This is how the object should look, this is a long one
Agenda:
1.
Make like a tree
2.
And
3.
Get out of here
Some more stuff here, and here and ::: ;s
Sadfdsf sdfdfeswrfew `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}