import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+\\.)\\s+([^\\r\\n]+)(?:[\\r\\n]*)";
final String string = "\n"
+ "This is a test of the agenda and objectives format\n"
+ " \n"
+ "This shouldn’t get picked up\n"
+ " \n"
+ "Dasdasdasd d asda sd : asd obe: sad neither shood this\n"
+ " \n"
+ "Objective: This is how the object should look, this is a long one\n"
+ " \n"
+ "Agenda:\n"
+ "1. \n"
+ "Make like a tree\n"
+ "2. \n"
+ "And\n"
+ "3. \n"
+ "Get out of here\n"
+ " \n"
+ "Some more stuff here, and here and ::: ;s\n"
+ "Sadfdsf sdfdfeswrfew ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}