// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+\.)\s+([^\r\n]+)(?:[\r\n]*)").unwrap();
let string = "
This is a test of the agenda and objectives format
This shouldn’t get picked up
Dasdasdasd d asda sd : asd obe: sad neither shood this
Objective: This is how the object should look, this is a long one
Agenda:
1.
Make like a tree
2.
And
3.
Get out of here
Some more stuff here, and here and ::: ;s
Sadfdsf sdfdfeswrfew ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}