import re
regex = re.compile(r"^(\d+\.)\s+([^\r\n]+)(?:[\r\n]*)", flags=re.MULTILINE)
test_str = ("\n"
"This is a test of the agenda and objectives format\n"
" \n"
"This shouldn’t get picked up\n"
" \n"
"Dasdasdasd d asda sd : asd obe: sad neither shood this\n"
" \n"
"Objective: This is how the object should look, this is a long one\n"
" \n"
"Agenda:\n"
"1. \n"
"Make like a tree\n"
"2. \n"
"And\n"
"3. \n"
"Get out of here\n"
" \n"
"Some more stuff here, and here and ::: ;s\n"
"Sadfdsf sdfdfeswrfew ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")