const regex = /^(\d+\.)\s+([^\r\n]+)(?:[\r\n]*)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+\\.)\\s+([^\\r\\n]+)(?:[\\r\\n]*)', 'mg')
const str = `
This is a test of the agenda and objectives format
This shouldn’t get picked up
Dasdasdasd d asda sd : asd obe: sad neither shood this
Objective: This is how the object should look, this is a long one
Agenda:
1.
Make like a tree
2.
And
3.
Get out of here
Some more stuff here, and here and ::: ;s
Sadfdsf sdfdfeswrfew `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}