$re = '/^(\d+\.)\s+([^\r\n]+)(?:[\r\n]*)/m';
$str = '
This is a test of the agenda and objectives format
This shouldn’t get picked up
Dasdasdasd d asda sd : asd obe: sad neither shood this
Objective: This is how the object should look, this is a long one
Agenda:
1.
Make like a tree
2.
And
3.
Get out of here
Some more stuff here, and here and ::: ;s
Sadfdsf sdfdfeswrfew ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);