using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"When: ([\w]{3}) ([\w]{3}) ([\d]{1,2}), ([\d]{4})";
string input = @"When: Mon Oct 27, 2013 to Fri Nov 1, 2013
<br />
<br />Event Status: confirmed</content>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}