re = /When: ([\w]{3}) ([\w]{3}) ([\d]{1,2}), ([\d]{4})/
str = 'When: Mon Oct 27, 2013 to Fri Nov 1, 2013
<br />
<br />Event Status: confirmed</content>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end