package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`When: ([\w]{3}) ([\w]{3}) ([\d]{1,2}), ([\d]{4})`)
var str = `When: Mon Oct 27, 2013 to Fri Nov 1, 2013
<br />
<br />Event Status: confirmed</content>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}